Issue with API services
Incident Report for BatchLeads
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 10:03 MST
Update
We are continuing to investigate this issue.
Posted Sep 13, 2021 - 07:47 MST
Update
We are continuing to investigate this issue.
Posted Sep 13, 2021 - 07:25 MST
Investigating
We are currently investigating an issue with our back-end API services that is impacting certain features in the BatchLeads application. We expect to have an update on a resolution to this issue within 2 hours.
Posted Sep 13, 2021 - 07:23 MST
This incident affected: Properties (Properties Import, Comparable), List Search (List Import), and Skip Tracing.