Issue with SkipTrace service
Incident Report for BatchLeads
Resolved
We faced an issue with our back-end API services that was impacting SkipTracing service in the BatchLeads application which was leading to some of the SkipTrace requests to fail. The issue was resolved within 2 hours
Posted Dec 17, 2021 - 08:30 MST