Issue with API services
Incident Report for BatchLeads
Resolved
This incident has been resolved.
Posted Sep 01, 2021 - 11:02 MST
Investigating
We are experiencing issues with one of our API services and are investigating.
Posted Sep 01, 2021 - 09:30 MST
This incident affected: Campaigns (Campaign Import).