Issue with SkipTrace service
Incident Report for BatchLeads
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 08:36 MST
Investigating
We are currently investigating an issue with our back-end API services that is impacting SkipTracing service in the BatchLeads application. We expect to have an update on a resolution to this issue within 2 hours.
Posted Sep 17, 2021 - 05:45 MST
This incident affected: Skip Tracing.